mdsk.net
当前位置:首页 >> 在UBuntu1604上安装OpEnCV3.2遇到问题求助 >>

在UBuntu1604上安装OpEnCV3.2遇到问题求助

Ubuntu 系统下opencv编译安装编译环境安装:sudo apt-get install build-essential必需包安装:sudo apt-get install cmake git libgtk2.0-dev pkg-config libavcodec-dev libavformat-dev libswscale-dev可选包安装:sudo apt-get install python-dev

可能是g++的版本老,不支持-fvisibility-inlines-hidden开关,这个是私有化内联函数的.

1. 下载opencv 2.2源码包, 2.2.0.tar.bz2,其实可以通过apt-get install命令找到opencv相关包直接安装,但是建议从源码包make,编译开始.2. 安装cmake. opencv官方论坛的安装教程,我看了下,貌似不适用于2.2版本了,2.2源码解压后得到

可以安装的 1.下载好opencv3.0.0的压缩包; tar -xvf opencv-3.0.0.tar.baz 2. cd opencv-3.0.0 sudo mkdir build (创建一个新的文件存放必需的安装文件信息) cdbuild sudo apt-get install libgtk2.0-dev 3查看是否安装了cmake 如果没有,则 sudo apt

这应该是你的Ubuntu系统上的gcc编译器与opencv要求的编译器不匹配造成,你可以上网查询一下各个版本的opencv都需要什么版本的gcc编译器,然后安装一个匹配版本的再对opencv进行编译安装

头文件没配置好其实可以在终端里编译的gcc `pkg-config --cflags opencv` -o XX.c XX `pkg-config --libs opencv`可以写成Makefile文件opencv官网上有配置eclipse的教程

opencv 2.2以后版本需要使用cmake生成makefile文件,因此需要先安装cmake.ubuntu下安装cmake比较简单,apt-get install cmakeapt-get install libgtk2.0-dev(下面两步安装编译必须的库)apt-get install pkg-config然后你们下载openc-2.4.3

opencv编译安装编译环境安装:[plain] view plain copysudo apt-get install build-essential 必需包安装:[plain] view plain copysudo apt-get install cmake git libgtk2.0-dev pkg-config libavcodec-dev libavformat-dev libswscale-dev 可选包安装:[plain]

由于ubuntu14.04/16.04都自带了python2.7和python3.5,所以无需在安装python.检查python是否安装:~ whereis python首先需要的是 pip:~ sudo apt-get install python3-setuptools python3-dev sudo easy_install3 pip然后是 numpy:~ pip3 install

试试这个教程:www.yyearth.com/article/13-12/opencv.html

网站首页 | 网站地图
All rights reserved Powered by www.mdsk.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com