mdsk.net
当前位置:首页 >> 我的linux系统装了2个版本的python,我怎么选择我... >>

我的linux系统装了2个版本的python,我怎么选择我...

如果你用的是pycharm 或wingide等ide 都可以选择python 的目录。 我电脑安装python2 和python3 which python /usr/bin/python which python3 /usr/local/bin/python3 按照这个在ide中设置

知道两个python的绝路径(如/usr/bin/python) 在写python时最顶部用#!/usr/bin/python 或者 /usr/bin/python python_script.py

如果是py文件的话,在开头选择:#!/usr/bin/python#!/usr/bin/python3如果想进入交互模式类似的,在终端中输入python或者python3

如果是py文件的话,在开头选择: #!/usr/bin/python #!/usr/bin/python3 如果想进入交互模式类似的,在终端中输入python或者python3

不要改系统默认的 python。python 2/3不兼容。很多系统级别的软件依赖于默认的python版本的。一旦修改,可能导致一些系统命令出错。 在你自己的项目里面,你可以使用完整路径选择版本。比如 /usr/bin/python2.7, /usr/bin/python3.4, /opt/pytho...

在python版本安装好后,需要执行如下类似命令,更改系统默认python路径,如 ln -fs /usr/local/python2.7/bin/python2.7 /usr/bin/python 更改系统默认python版本为python2.7 关于更多Linux的学习,请查阅书籍《linux就该这么学》。

如果是py文件的话,在开头选择:#!/usr/bin/python#!/usr/bin/python3如果想进入交互模式类似的,在终端中输入python或者python3

要查安装在哪里:locate python 要启动:python 试一试,上面的命令都是在终端里输入的!

一般系统是预装2.7你编译安装3.0+的给系统路径${PATH}里的第一个路径里加一个ln每次命令敲那个名字就可以了

/usr/bin/python和/usr/local/bin/python下面,一般是符号链接,优先使用后者, 如果有2.6和2.7两个版本,并且 /usr/bin/python --> /usr/bin/python2.6 /usr/local/bin/python --> /usr/local/bin/python2.7 此时系统默认使用2.7, 如果想切换至...

网站首页 | 网站地图
All rights reserved Powered by www.mdsk.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com