mdsk.net
当前位置:首页 >> 调用两个js文件发生冲突 一个是jquEry.min.js 一个... >>

调用两个js文件发生冲突 一个是jquEry.min.js 一个...

不用修改: 在使用自己的js时加上 jQuery.noConflict(); 这样就可以使用自己js中的$了,当然在之后jQuery中的的$就得使用jQuery代替了

你这个不是冲突了,,而是你的入口函数覆盖了,,js加载生命周期的问题哟,,把你页面里的 onload 是不是有多个 去掉试下 望采纳!!!

多jquery或者与其他js框架混用时,需要在某一个jquery中插入js语句xxx=$,xxx为自定义字符串。

如果版本相同,那就只用一个(这和你单个网站一样),如果是不同版本,如就得看它们之间的跨度是多久及你的页面的代码了。 因为有些代码可能不支持新版,这个你需要做测试,最简单的是直接把文件的版本直接改为最新,然后把功能或动作操作下,在...

这俩html在同一个标签里面加载进来了吧?两个引用同一个js可能会出现属性名方法名冲突的情况

1.区别: jquery官网提供2种jQuery的下载,一种是jquery.js另一种是jquery.min.js 文件名不一定完全相同,但通常情况下: jquery.js是完整的未压缩的jQuery库,文件比较大,一般用于阅读学习源码或修改源码,一般不用于线上项目。 jquery.min.js...

用动态加载的办法 function checkJquery() { if(!(window.jQuery)) { var s = document.createElement('script'); s.setAttribute('src', 'http://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js'); s.setAttribute('type', 'text/j...

两个功能是一样的,min的那个是压缩过的,文件比较小,因为把空格什么的都压缩掉了,所以打开看上去比较乱,如果你想研究一下里面的代码,就用没有min的那个。

应该是js文件中有的函数在高版本中被放弃了,比如live()从1.9开始就被on()代替了,不嫌麻烦可以找出来替换掉,不然就jquery降到兼容的版本

因为你的其他js文件是用jquery写的,所以要写引入jquery文件,等于是先拿工具(jquery),再拿工具操作(其他js) 如果你引入的是纯的js,不是用jquery这种类库写的,那之前之后引入都无所谓,因为不搭……

网站首页 | 网站地图
All rights reserved Powered by www.mdsk.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com